·
The issue has been fixed.
Resolved
Identified
The servers on the data canter seems unreachable at this point.
Investigating
Major fault on data center detected.